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Internet of Things

"loT involves extending Internet connectivity to any range of traditionally dumb or
non-internet-enabled physical devices and everyday objects."

Connected devices make it easy to connect, monitor & control your world!

In this workshop we'll explore how we can use Grafana together with the ESP32
platform to monitor our surroundings and visualize data over time.




ESP-what?

In 2014 Espressif Systems launched the ESP8266, an
all-in-one chip with a 32-bit CPU and WiFi

It became hugely popular both with hobbyists and
device manufacturers because of its capabilities and
low per-unit cost.

It's also possible to program the ESP8266 with the
Arduino IDE, and to use the huge Arduino library.




ESP32

In 2016, Espressif released the successor to
the ESP8266, the ESP32:

ESP32-PICO-D4 LDO USB-to-UART Bridge

Faster dual-core CPU
More memory

Bluetooth 4.2

More connectivity options!

This tiny chip is amazing, and with the ESP32
Arduino core it too can be programmed like an
Arduino




What's in the bag?

-  ESP32-PICO-KIT V4.1
The brains of the operation

- DHT11 Temperature and Humidity sensor
What we'll use to gather data

- Jumper wires

- Micro-USB cable
Plumbing

If you only have USB-C, let us know and we have USB-C to USB-A adapters




So, what are we going to do with it?

Observe temperature and humidity

in the room on a regular basis
74 °F 72 °F 19%

- Calculate the Heat Index

- Send the data to a Time Series LT mERE
DataBase (TSDB) for storage -
- Graphite J |
- Prometheus B

- Graph it with Grafana!




Hardware

USB
- Plug the USB cable into the ESP32

Power

Connect the - pin on the DHT11 to GND on the ESP32 (2nd pin)
- Connect the + pin on the DHT11 to 3v3 on the ESP32 (3rd pin)

Signal

- Connect the out pin on the DHT11 to pin 32 on the ESP32 (13th pin)




Hardware




Getting Started

All the links you'll need are at:

https://github.com/DanCech/loTWorkshop




CP210x Driver

Note: Only required if your OS doesn't recognize the USB Serial automatically

Download the Silicon Labs CP210x UART to USB Driver (URL in README)

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

OSX: Unzip, open the .dmg image
Double click the .pkg and follow the prompts

When prompted you will have to open Security & Privacy and allow software from
“Silicon Laboratories Inc”
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The Arduino IDE

SOFTWARE LLE e ENGLISH
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- arduino.cc

ARDUINO
WEB EDITOR CETTING STARTED

ing online

- Download the 1.8.8 IDE for your OS e O -

= InSta” |t Download the Arduino IDE

Windows installer, for Windows XP and up
Windows zIP file for non admin install

ARDUINO 1.8.8 Windows app Requires Win 810r 10

The open-source Arduino Software (IDE) makes it easy to Get 52

v e code and upload it to the board. It runs on

indows, 0S X, and Linux. The environment is

n in Java and based on Processing and other of

source software

This software can be used with any Arduino board. Linux 32 bits

Refer to the Getting Started page for Installation Linux 64 bits

Instructiont Linux ARM

Mac OS X 10.8 Mountain Lion or newer

Release Notes
Source Code
Checksums (sha512)

https://www.arduino.cc/en/Main/Software




The ESP32 core

Settings  Network

Sketchbook location:

This open-source board definition adds e

. f 2 [ Automatic | 100 T % (requires restart of Arduino)
support in the Arduino IDE for programming g&=

Default theme | (requires restart of Arduino)

0! output during: [] compilation ["] upload
ESP32 boards. e

Verify code after upload

https://github.com/espressif/arduino-esp32 |

Agaressively cache compiled core

e -> .ino)

- Open File > Preferences

ressif.com/d| fpackage_esp32_index.json

- Add a Boards Manager URL

- https://dl.espressif.com/dl/package esp32 index.json




The ESP32 Core (cont)

©® Boards Manager

Type Al

Open Boards Manager

esp32 by Espressif Systems version 1.0.1 INSTALLED
Boards included in this package:

ESP32 Dev Module, WEMOS LoLin32.
More info

Tools -> Boards: *
-> Board manager
Wait for it to update the list

Search for ESP32

Install version 1.0.1

Remove




Libraries

To read data from the DHT11 sensor we will use the libraries published by
Adafruit

— Open ' @ sketch_feb20a | Arduino 1.8.8 = O X
File Edit Sketch Tools Help
Verify/Compile Ctrl+R
Upload Ctrl+U
sketct Upload Using Programmer Ctrl+Shift+U
Export compiled Binary Ctrl+Alt+S

Show Sketch Folder Ctrl+K
Include Library Manage Li%aries... Ctrl+Shift+I
Add File...

void loop () { Add .ZIP lerary

// put your main code here, to run repd

Arduino libraries
EEPROM

HID

SPI
SoftwareSerial
Wire




Adafruit DHT Sensor Library

@@ Library Manager

Type All v Topic |All v dht

Edulntro by Arduino LLC

Library used for super-fast introduction workshops Is intended to be used with Arduino UNO / MICRO / MEGA / NANO / MKR and a set of basic
components (led, button, piezo, LM35, thermistor, DHT11, and servo) as a way to introduce people to the basic aspects of Arduino during short
workshops.

More info

DHT sensor library by Adafruit
Arduino library for DHT11, DHT22, etc Temp & Humidity Sensors Arduino library for DHT11, DHT22, etc Temp & Humidity Sensors

More info
Version 1.3.4 v
DHT sensor library for ESPx by beegee_tokyo

Arduino ESP library for DHT11, DHT22, etc Temp & Humidity Sensors Optimized libray to match ESP32 requirements. Last changes: Use
correct field separator in keywords.txt.
More info

Grove Temperature And Humidity Sensor by Seeed Studio

Arduino library to control Grove Temperature And Humidity Sensor, it contains chip DHT11 AM2302. This temperature & humidity sensor
provides a pre-calibrated digital output. A unique capacitive sensor element measures relative humidity and the temperature is measured by a
negative temperature coefficient (NTC) thermistor. It has excellent reliability and long term stability.

More info




Adafruit Unified Sensor Library

i @@ Library Manager

Type All v Topic All v |adafruit unified

More info

Adafruit LIS3DH by Adafruit

Library for the Adafruit LIS3DH Accelerometer. Designed specifically to work with the Adafruit LIS3DH Breakout, and is based on Adafruit's
Unified Sensor Library.

More info

Adafruit LSM303DLHC by Adafruit

Unified sensor driver for Adafruit's LSM303 Breakout (Accelerometer + Magnetometer) Unified sensor driver for Adafruit's LSM303
Breakout (Accelerometer + Magnetometer)

More info

Adafruit TSL2561 by Adafruit

Unified sensor driver for Adafruit’'s TSL2561 breakouts Unified sensor driver for Adafruit's TSL2561 breakouts
More info

Adafruit Unified Sensor by Adafruit

Required for all Adafruit Unified Sensor based libraries. A unified sensor abstraction layer used by many Adafruit sensor libraries.
More info

Version 1.0.2 v >

Close




NTPClient Library

@@ Library Manager

Type All v Topic |All v | ntpcli

NTPClient by Fabrice Weinberg
An NTPClient to connect to a time server Get time from a NTP server and keep it in sync.
More info

Version 3.1.0 V|| Install

s

EasyNTPClient by Harsha Alva
Library to read time from Network Time Protocol (NTP) servers. Handles the connection to an NTP pool and parses Internet Time to UNIX time
format.

More info

NtpClientLib by German Martin

Ntp Client Library Library to get system sync from a NTP server. Based on code from NTP client example. Currently, it works on ESP8266 based
boards. I've made it compatible with Arduino boards w Eternet module but I have not had the opportunity to test it. Please, add an issue to GitHub if
you find a bug. NOTICE: After version 2.0.0 library structure has changed. Please refer to README file on github repository.

More info




Download the project

We need to download the project files into your arduino IDE sketchbook folder

You can do that via git by going to your sketchbook folder and running:
git clone https://github.com/DanCech/IoTWorkshop.git, or

You can download the .zip from the link in the project readme and extract it
into your sketchbook folder

After downloading, copy config.h.example to config.h, this file will hold
the configuration for the device.




Open the loTWorkshop project in Arduino IDE

File Edit Sketch Tools Help

B E K
| '

| Open an Arduino sketch...

Look in: loTWorksh

ﬂ Name

.git
|4 .gitignore
- = config.h
- 4] config.h.example
4] dashboard.json
iIoTWorkshop.ino
|4 README.md

Quick access

Desktop
m
Libraries

&

This PC

e

Network

Object name:

Objects of type: Al Files (**)

(< Xz

s [@v

Date modified
2/6/2019 5:31 PM
1/19/2019 6:40 PM
2/20/2019 5:51 PM
2/20/2019 5:51 PM
1/23/2019 9:16 AM
2/10/2019 4:26 PM
2/20/2019

Type

File folder
GITIGNORE File
H File
EXAMPLE File
JSON File
“Arduino file

loTWorksh ~

v




Let's walk through the sketch

- Line 1-7: Include required libraries & config.h

- Line 10-11: Set up NTP client

- Line 14: Set up DHT Sensor

- line s Set up HTTP client for Hosted Metrics
- Line 20: Set up UDP client for carbon protocol

- Line 25-42: setupWiFi function to connect to WiFi network
- Line 47-60: formatTime function to format a timestamp

- Line 65-91: submitHostedGraphite function to send to hosted graphite
- Line 96-110: submitCarbon function to send to hosted prom.
- Line 115-127: setup function to initialize at startup

- Line 132-192: 1oop function, where the magic happens




vold setup ()

- This function is called when the ESP32 starts

- It starts the Serial debug connection

- Calls setupWiFi() to connect to the WiFi network
- Initializes the NTP (Network Time Protocol) client
- Initializes the DHT sensor




voild ieen ()

The core of the system, this function is called in an endless loop, it:

- checks the WiFi connection and reconnects if required

- updates the time via NTP and gets the current timestamp

- reads the current temperature and humidity from the DHT11 sensor
- calculates the heat index

- outputs the readings via Serial

- sends the stats to Hosted Graphite

- sends the stats to carbon relay

- sleeps for 30 seconds




Create TSDB & Grafana instance

Go to

https://grafana.com/loki#get

and follow the instructions to get set up.

(If you already have a Hosted Metrics instance, feel free to use that)




CO R e T

This file contains the configuration for the project

= WIS e GrafanaCon WiFi, Sponsored By...

- WIFI PASSWORD packetdotcom

- TZATCEECHN timezone offset to use for formatted dates

=0 ZED an identifier for this sensor

- INTERVAL reporting interval

- DHT PIN ESP32 pin the DHT11 signal is connected to
- . DHT e DHT11 or DHT22 (both are supported by the

lib)




config.h

- HM API KEY
MetricPublisher role

- HM GRAPHITE HOST
centrall.grafana.net

- HM GRAEPFHLTESE FRE R

- CARBON HOST

- - CAREONSTECIES]

- HM ROOT CA
SSL validation

Grafana.com API key with
graphite-us-

Hosted Graphite Instance ID
IP Address of carbon server
carbon server port
The root CA cert to use for




Setting the board type

This tells the Arduino IDE which profile and base libraries to use when compiling
the firmware image, and how to flash it to the board

- Open the "Tools" menu

- In the Board submenu, select "ESP32 Pico Kit"
- Plug in the USB cable

- In the Port submenu, select the new COM port




The serial monitor

This allows us to see the debug output from the board, including the bootloader

- Select "Serial Monitor" from the Tools menu
- Set the port speed to 115200




Building and uploading the firmware

Use the Upload button in the Ul to build and upload the firmware to the ESP32

- The serial monitor will be blank during the upload
- Progress will be displayed in the screen at the bottom of the IDE

- Once the upload is complete, the Serial Monitor will show:
Start up & connect to WiFi
Readings from the sensor
Results of submitting metrics




The dashboard

Temperature Heat Index Humidity

- 3 Singlestat panels
- Temperature \ \ \
- Heat Index
) 74 °F 72 °F 19%

Humidity
- 1 Graph panel

https://grafana.com/dashboards/9848 “






